Google Chrome on Linux!

I got Google Chrome for Linux!  From one of those ad links at the top of GMail, I clicked through to Chrome, and found out that they have a version that works for Linux.  I am actually using it now for this post.

First, they have a place you can enter your email address for notification when the full version comes out.  Currently, it is under development.

http://www.google.com/chrome/intl/en/linux.html

From, that page, you will find a link to the Early Access Release Channels, which has the links to downloading Chrome.  If you scroll down to the bottom of the page, you will find the link to the deb package that you can install.

svnsync

I have decided to try svnsync instead of using git directly as I posted here and here.  Since I am a single developer, I was hoping it would be easier this way.  I found another article with tips here.

First, let me just check my installation:

skp@pecan:~$ svnsync --version
svnsync, version 1.5.4 (r33841)
 compiled Aug  7 2009, 01:44:11

Copyright (C) 2000-2008 CollabNet.
Subversion is open source software, see http://subversion.tigris.org/
This product includes software developed by CollabNet (http://www.Collab.Net/).

The following repository access (RA) modules are available:

* ra_neon : Module for accessing a repository via WebDAV protocol using Neon.
 - handles 'http' scheme
 - handles 'https' scheme
* ra_svn : Module for accessing a repository using the svn network protocol.
 - with Cyrus SASL authentication
 - handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
 - handles 'file' scheme

Here are some other quick discoveries that I found:

You can get help by typing

svnsync help

This will give the list of commands supported: init, sync, and copy-revprops.  Then, you can get help on a specific command, such as init, with:

svnsync help init

One of the things I noticed was this warning which has me worried because I have already started committing to the repository with git:

You should not commit to, or make revision property changes in,
the destination repository by any method other than 'svnsync'.
In other words, the destination repository should be a read-only
mirror of the source repository.

So, lets go for it.

First, I am going to make my local repository:

mkdir project-sarah
git svn clone --username myusername https://project-sarah.googlecode.com/svn/trunk

Now, I am going to try to initialize the syncing:

svnsync init --username myusername --password mypassword  https://project-sarah.googlecode.com/svn file://home/skp/app/git-workspace/project-sarah

Here is the message I got back:

svnsync: Cannot initialize a repository with content in it

So, I guess unless I want to try to get Google Code to delete the repository and start over, I am out of luck here.  Maybe this will help someone else though.

Resources

How I moved my code repository to Google Code

Trying to Upgrade PulseAudio

I first tried to install from this respository, but it wouldn’t install.  There was an error message about maybe one of the packages being held, and it could resolve everything.

So, I found another blog post that had a better repository to install from.  So, I followed these directions:

How to Install the Latest PulseAudio (0.9.15) in Ubuntu Jaunty

Here is a quick summary:

Installed repository:

deb http://ppa.launchpad.net/themuso/ppa/ubuntu jaunty main

Installed key:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B88A1AA8

Updated all of the packages

Now:

pulseaudio –version

pulseaudio 0.9.15

So, I rebooted, and I will let you know if things start working better!

PulseAudio Log Busting

This page has moved.  Please update your links:
http://linuxsagas.digitaleagle.net/2009/09/16/pulseaudio-log-busting/

I have started looking into several of the messages that I have been seeing in my logs to see if I can get rid of some of the bugginess.  For those who like the GUI, I have found a nice app for looking at the logs: Administration > Log File Viewer.

Please comment if you have any ideas on any of these.  At this point, I haven’t tried any fixes.

Message:

Sep 15 06:25:01 pecan pulseaudio[3559]: module-console-kit.c: GetUnixUser() call failed: org.freedesktop.DBus.Error.UnknownMethod: Method “GetUnixUser” with signature “” on interface “org.freedesktop.ConsoleKit.Session” doesn’t exist

Links:

Bug #390528

Message:

Sep 14 13:59:19 pecan pulseaudio[3559]: alsa-util.c: Device hw:1 doesn’t support 2 channels, changed to 1.

Here are the bug reports I have been looking at:

One possible solution is from this post, where I could make some edits to the /etc/pulse/default.pa file.

I think I might try adding this repository and upgrading to a later version first.  I noticed they are listing version 0.9.17 currently.

Message:

pecan pulseaudio[3559]: protocol-native.c: Failed to push data into queue

This message was while I was on a Skype call.

Links

sounds stops working in 8.10 (Ibex)

They mention that one possible fix is to change the default fragments settings in the default.pa file.  Another suggestion is that upgrading to the latest version might fix it.

Skype + PulseAudio

I have been fighting to get Skype to work so that I could make calls.  Getting PulseAudio to work with Skype has been a challenge. (“Back to Alsa”, “Sound in Jaunty”).

I recently found out that the latest version supports PulseAudio natively!  You can download it from here.  Currently, they are at version 2.1.0.47.

Previously, I had downloaded from the Medibuntu repository, which you can see here.  But, they only offer version 2.0.0.72.

One thing I noticed is that they recommend version 0.9.15 or greater.  You can check to see what version you have with this command:

pulseaudio –version

So, here is a screenshot of the audio setup screen for this new version of Skype.  Notice that PulseAudio is an option now.

screenshot

Posted in Skype, sound. 1 Comment »

WebEx Error

I have been struggling to get WebEx to work now that I have upgraded to Ubuntu 9.04.  I get the error below, and it failes to continue loading.  If anyone has any ideas, please let me know.  I did just upgrade to Firefox 3.5, but that didn’t fix the problem.  I also did a search on Google, and that didn’t turn up anything.

java.io.EOFException
at java.io.DataInputStream.readInt(DataInputStream.java:375)
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:628)
at sun.security.provider.JavaKeyStore$JKS.engineLoad(JavaKeyStore.java:38)
at java.security.KeyStore.load(KeyStore.java:1185)
at com.sun.deploy.security.DeploySigningCertStore$1.run(DeploySigningCertStore.java:154)
at java.security.AccessController.doPrivileged(Native Method)
at com.sun.deploy.security.DeploySigningCertStore.loadCertStore(DeploySigningCertStore.java:137)
at com.sun.deploy.security.DeploySigningCertStore.load(DeploySigningCertStore.java:107)
at com.sun.deploy.security.DeploySigningCertStore.load(DeploySigningCertStore.java:92)
at com.sun.deploy.security.ImmutableCertStore.load(ImmutableCertStore.java:43)
at com.sun.deploy.security.TrustDecider.isAllPermissionGranted(TrustDecider.java:245)
at com.sun.deploy.security.TrustDecider.isAllPermissionGranted(TrustDecider.java:218)
at com.sun.deploy.security.TrustDecider.isAllPermissionGranted(TrustDecider.java:208)
at sun.plugin.security.PluginClassLoader.getPermissions(PluginClassLoader.java:150)
at java.security.SecureClassLoader.getProtectionDomain(SecureClassLoader.java:192)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:171)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:143)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:682)
at sun.applet.AppletPanel.createApplet(AppletPanel.java:785)
at sun.plugin.AppletViewer.createApplet(AppletViewer.java:2315)
at sun.applet.AppletPanel.runLoader(AppletPanel.java:714)
at sun.applet.AppletPanel.run(AppletPanel.java:368)
at java.lang.Thread.run(Thread.java:619)

I did check to make sure I had the ubuntu-restricted-extras and the libstdc++5 installed from this earlier post.

Follow

Get every new post delivered to your Inbox.