Installing Mono Dependencies

I pulled the latest version of Gnome-RDP, and ran into a few errors when compiling.

screenshot_134

Here is how I solved the problems:

For the “Reference ‘Mono.Cairo’ not found on system”, I found a tutorial page with links to the download.  I downloaded the latest version from the releases page.

I uncompressed the download into “cairo-1.8.8”, and opened a command-line into that directory.  I ran the configure with my custom path because I have a specially compiled version of MonoDevelop that I am using:

./configure --prefix=$MONO_PREFIX

Then, I compiled and installed:

make
make install

Finally, my project was requiring a specific version, and I downloaded a newer version.  So, I just unchecked the require version flag:

screenshot_141

For the “Assembly ‘NDesk.DBus'” error, I downloaded the library from the DBusSharp page.  Then, I uncompressed it into the folder “ndesk-dbus-0.6.0”.  Again, I added the prefix option because I had a special path for MonoDevelop:

./configure --prefix=$MONO_PREFIX

Then, I compiled and installed:

make
make install

Finally, the /tmp/tmp22c1daf8.tmp problem was caused by this message:

** (/home/skp/app/gnome-rdp/monodevelop/lib/mono/2.0/gmcs.exe:4434): WARNING **: The following assembly referenced from /home/skp/app/gnome-rdp/gnome-rdp-temp/gnome-rdp/gnome-rdp-dockyplugin/References/Docky.Items.dll could not be loaded:
Assembly:   notify-sharp    (assemblyref_index=17)
Version:    0.4.0.0
Public Key: 2df29c54e245917a
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/home/skp/app/gnome-rdp/gnome-rdp-temp/gnome-rdp/gnome-rdp-dockyplugin/References/).
** (/home/skp/app/gnome-rdp/monodevelop/lib/mono/2.0/gmcs.exe:4434): WARNING **: The following assembly referenced from /home/skp/app/gnome-rdp/gnome-rdp-temp/gnome-rdp/gnome-rdp-dockyplugin/References/Docky.Items.dll could not be loaded:     Assembly:   notify-sharp    (assemblyref_index=17)     Version:    0.4.0.0     Public Key: 2df29c54e245917aThe assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/home/skp/app/gnome-rdp/gnome-rdp-temp/gnome-rdp/gnome-rdp-dockyplugin/References/).

I found the library’s home page, but I didn’t see a release yet.  So, I had to download from the repository.  First, I had to have the hg command installed:

sudo apt-get install mercurial

Then, I used the command from the homepage to download the code:

hg clone http://hg.circular-chaos.org/notify-sharp

But, that is a broken link.  Well, I am running out of time for this one on my lunch break, so I will have to come back to it.  I found a post suggesting to pull it from Gnome-Do.  I probably already have it installed somewhere.


Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: