Lirc and Volume

We have been having trouble with the remote not being able to control the volume on our Mythbuntu installation.  I just came across the pulseaudio-module-lirc package –

sudo apt-get install pulseaudio-module-lirc

My mute button didn’t work, so I tried adding the lirc configuration as explained in this thread.  It didn’t work.  The volume up and down did work though before I added that configuration.  The only thing I didn’t like was that it didn’t show the visual volume display on the screen.

On a side note, I found another application that looked interesting from this post: gizmod.  Actually, even though the post says they don’t have deb packages, I found one already in the repositories!

Another handy program is unclutter:

sudo apt-get install unclutter

It hides the mouse cursor so that you don’t see it in front of the videos you are watching.  I found it here, and here is another post about it.

Pulse Problems on Karmic

After installing Karmic Koala (Ubuntu 9.10), I was thrilled about the sound working so much better.  The latest version of Skype supported pulse directly, and everything seemed to be great.

But then, the sound quit working suddenly, and nothing would bring it back.  I checked the Alsa volume settings, I tinkered with several of the config files, and I compared to the configuration with the live CD.

Finally, what solved my problem was:

  • deleted (backed up) ~/.pulse
  • rebooted
  • turned up my volume with the applet by the clock
  • ran speaker-test
  • I heard noise!

I will continue to keep my eye out for what is breaking the sound, but at least I have a solution.  Please let me know if anyone else has this problem.

Here are some of the links that I checked:

Trying to Upgrade PulseAudio

I first tried to install from this respository, but it wouldn’t install.  There was an error message about maybe one of the packages being held, and it could resolve everything.

So, I found another blog post that had a better repository to install from.  So, I followed these directions:

How to Install the Latest PulseAudio (0.9.15) in Ubuntu Jaunty

Here is a quick summary:

Installed repository:

deb http://ppa.launchpad.net/themuso/ppa/ubuntu jaunty main

Installed key:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B88A1AA8

Updated all of the packages

Now:

pulseaudio –version

pulseaudio 0.9.15

So, I rebooted, and I will let you know if things start working better!

PulseAudio Log Busting

This page has moved.  Please update your links:
http://linuxsagas.digitaleagle.net/2009/09/16/pulseaudio-log-busting/

I have started looking into several of the messages that I have been seeing in my logs to see if I can get rid of some of the bugginess.  For those who like the GUI, I have found a nice app for looking at the logs: Administration > Log File Viewer.

Please comment if you have any ideas on any of these.  At this point, I haven’t tried any fixes.

Message:

Sep 15 06:25:01 pecan pulseaudio[3559]: module-console-kit.c: GetUnixUser() call failed: org.freedesktop.DBus.Error.UnknownMethod: Method “GetUnixUser” with signature “” on interface “org.freedesktop.ConsoleKit.Session” doesn’t exist

Links:

Bug #390528

Message:

Sep 14 13:59:19 pecan pulseaudio[3559]: alsa-util.c: Device hw:1 doesn’t support 2 channels, changed to 1.

Here are the bug reports I have been looking at:

One possible solution is from this post, where I could make some edits to the /etc/pulse/default.pa file.

I think I might try adding this repository and upgrading to a later version first.  I noticed they are listing version 0.9.17 currently.

Message:

pecan pulseaudio[3559]: protocol-native.c: Failed to push data into queue

This message was while I was on a Skype call.

Links

sounds stops working in 8.10 (Ibex)

They mention that one possible fix is to change the default fragments settings in the default.pa file.  Another suggestion is that upgrading to the latest version might fix it.

Skype + PulseAudio

I have been fighting to get Skype to work so that I could make calls.  Getting PulseAudio to work with Skype has been a challenge. (“Back to Alsa”, “Sound in Jaunty”).

I recently found out that the latest version supports PulseAudio natively!  You can download it from here.  Currently, they are at version 2.1.0.47.

Previously, I had downloaded from the Medibuntu repository, which you can see here.  But, they only offer version 2.0.0.72.

One thing I noticed is that they recommend version 0.9.15 or greater.  You can check to see what version you have with this command:

pulseaudio –version

So, here is a screenshot of the audio setup screen for this new version of Skype.  Notice that PulseAudio is an option now.

screenshot

Posted in Skype, sound. 1 Comment »

Back to Alsa

I have tried to make Skype work, but I have finally given up on Pulse Audio.  My problem right now is that I can hear the other person, but I can’t make it loud enough for the other person to hear me.

These instructions I found here: Pulse + skype delay issues in jaunty.

This kills all of the currently running pulseaudio processes:

#killall pulseaudio

This uninstalls pulseaudio:

#sudo aptitude remove pulseaudio

It gave this output:

The following packages are BROKEN:
 ubuntu-desktop
The following packages will be REMOVED:
 linux-headers-2.6.28-13{u} linux-headers-2.6.28-13-generic{u} pulseaudio
0 packages upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 76.5MB will be freed.
The following packages have unmet dependencies:
 ubuntu-desktop: Depends: pulseaudio but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
ubuntu-desktop

Leave the following dependencies unresolved:
libpulsecore9 recommends pulseaudio
Score is -81

Accept this solution? [Y/n/q/?]

I went ahead and said yes.  Again, the output is:

The following packages will be REMOVED:
 linux-headers-2.6.28-13{u} linux-headers-2.6.28-13-generic{u} pulseaudio
 ubuntu-desktop{a}
0 packages upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 76.5MB will be freed.
Do you want to continue? [Y/n/?]

Now, installing esound to replace Pulse Audio:

$sudo aptitude install esound

It gave this output, to which I said yes:

The following packages are BROKEN:
 pulseaudio-esound-compat
The following NEW packages will be installed:
 esound
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.1kB of archives. After unpacking 102kB will be used.
The following packages have unmet dependencies:
 pulseaudio-esound-compat: Conflicts: esound but 0.2.40-0ubuntu3 is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
pulseaudio-esound-compat

Score is 119

Accept this solution? [Y/n/q/?]

Finally, remove the pulse audio configuration file.

#sudo aptitude remove /etc/X11/Xsession.d/70pulseaudio

No, I can hear only out of one side of the headphones, and I still don’t have the volume for the Mic.  I think my biggest problem is that I can’t turn on the Mic Boost!  Here are some posts I have searched.

Ddell Inspiron 1720, Ubuntu with Skype & Mic problem please……

Bug #289419

This might have a solution!

So, now, I am going to try to go back to pulse audio.

First, remove esound:

#sudo aptitude remove esound

result:

The following packages will be REMOVED:
 esound
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.

Now, reinstalling pulse audio

#sudo aptitude install pulseaudio

Reinstalling one of the dependencies that I noticed it removed earlier:

#sudo aptitude install ubuntu-desktop

Now, installing the volume panel that is supposed to fix my problem (from here):

#sudo apt-get install gnome-volume-control-pulse

I rebooted just to make sure I was doing it right.  Then, I found the sound applet by the clock in the notification area.  I was able to right click on the sound icon and choose “Sound Preferences”.  On the input tab, the volume was set at somewhere between 50% and 75%.  When I adjusted it up, I had plenty of volume.

Sound in Jaunty

When I upgraded to Juanty, my sound did not work on my laptop.  I found a couple of posts that helped me get it back up and running.

Ubuntu Forums: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support

I think I found this post from this one:

Ubuntu Forums: No sound after upgrade from 8.10 to 9.04

I have had trouble with the pulseaudio service not running, and so I did a little research to find the command to restart it.  I haven’t tried these so be warned.

This article suggests:

pulseaudio -k; sleep 4; pulseaudio -vv

This article points out that you can use “pulseaudio –check” to see if an instance is running.  Also, they mention that if the -k doesn’t work, you can use “killall pulseaudio”.

Finally, since I use Skype, I have been contemplating going back to alsa.  I am not ready for that, but I am keeping this in my back pocket:

Mariuz’s Blog: Pulse + skype delay issues in jaunty

Follow

Get every new post delivered to your Inbox.